Sync Unavailable

Major incident Sync API Notifications Email Delivery Account Management (including signup) CalDAV and CardDAV
2024-10-19 17:32 EDT · 23 minutes

Updates

Resolved

This incident has been resolved.

October 19, 2024 · 13:55 EDT
Investigating

It seems like a general network issue - still investigating

October 19, 2024 · 13:36 EDT
Investigating

We are currently investigating this issue.

October 19, 2024 · 13:32 EDT

← Back