System outage

Major incident Sync API Notifications Account Management (including signup) CalDAV and CardDAV
2024-06-27 15:05 EDT · 19 minutes

Updates

Resolved

This incident has been resolved.

June 27, 2024 · 11:25 EDT
Investigating

We are currently investigating this issue.

June 27, 2024 · 11:05 EDT

← Back