Reset Password Requests Failing

Major incident Account Management (including signup)
2023-03-15 14:22 EDT · 1 hour, 20 minutes

Updates

Resolved

This incident has been resolved.

March 15, 2023 · 11:43 EDT
Monitoring

A fix has been implemented and we are monitoring the results.

March 15, 2023 · 11:20 EDT
Investigating

The issue has been identified and a fix is being implemented.

March 15, 2023 · 10:43 EDT
Investigating

We are currently investigating this issue.

March 15, 2023 · 10:22 EDT

← Back