Offline download failing for customers

Major incident Sync
2022-03-22 09:15 EDT · 1 hour, 15 minutes

Updates

Resolved

This incident has been resolved.

March 22, 2022 · 06:30 EDT
Investigating

We are currently investigating this issue.

March 22, 2022 · 05:15 EDT

← Back