Degraded Performance for Customers

Minor incident Sync API Notifications Email Delivery Account Management (including signup) CalDAV and CardDAV
2021-11-07 02:22 EST · 1 hour, 20 minutes

Updates

Resolved

This incident has been resolved.

November 6, 2021 · 23:43 EDT
Investigating

The issue has been identified and a fix is being implemented.

November 6, 2021 · 23:07 EDT
Investigating

We are currently investigating this issue.

November 6, 2021 · 22:22 EDT

← Back