Investigating Billings Pro and CalDAV connectivity issues

Major incident CalDAV and CardDAV
2021-02-16 18:13 EST · 1 hour, 50 minutes

Updates

Resolved

This incident has been resolved.

February 16, 2021 · 15:03 EST
Investigating

Our network provider confirmed that there is a widespread network issue. We’ll update you as soon as we have more information about the timeline.

February 16, 2021 · 14:19 EST
Investigating

We are continuing to work on a fix for this issue.

February 16, 2021 · 13:19 EST
Investigating

The issue has been identified and a fix is being implemented.

February 16, 2021 · 13:13 EST

← Back