Outage
Major incident
CalDAV and CardDAV
2021-01-21 04:11 EST
· 1 hour, 12 minutes
Updates
Monitoring
January 21, 2021 · 00:14 EST
A fix has been implemented and we are monitoring the results.
Investigating
January 20, 2021 · 23:11 EST
We are investigating a performance issue will CalDAV. We will post updates as we learn more.
← Back