Slow CalDAV and CardDAV performance

Minor incident CalDAV and CardDAV
2020-11-14 18:38 EST · 2 minutes

Updates

Resolved

This incident has been resolved.

November 14, 2020 · 13:40 EST
Investigating

We are investigating an issue where the CalDAV and CardDAV services are slow to respond for some customers.

November 14, 2020 · 13:38 EST

← Back