Connectivity issues with Daylite Cloud and Billings Pro

Major incident Sync API Notifications Email Delivery Account Management (including signup) CalDAV and CardDAV
2020-10-27 03:42 EDT · 2 minutes

Updates

Resolved

This incident has been resolved.

October 26, 2020 · 23:45 EDT
Investigating

Some customers are not able to access Billings Pro and Daylite.

October 26, 2020 · 23:42 EDT

← Back