Intermittent Sync Delays

Minor incident Sync Notifications Push Notifications Push Syncs Webhooks Email Delivery CalDAV and CardDAV
2025-02-21 11:16 EST · 1 hour, 39 minutes

Updates

Resolved

The issue has been resolved.

February 21, 2025 · 12:55 EST
Investigating

We are investigating an issue where some customers are having intermittent sync delays.

February 21, 2025 · 11:16 EST

← Back